Honda Twins banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
hey guys, I have a 67 K0 Black Bomber. The speedo and tach both wont work. The needles jump all around while riding the bike, Ive inpected the speedo cable and the spindle spins fine and has plenty of grease on it from the previous owner. I havent jumped into the tach yet as I wanted to get the speedometer done first , both cables are the original btw. I was also wondering if anyone knows where theres a how to video on setting my clutch ?? Thanks
 

·
Premium Member
Joined
·
2,838 Posts
pull the cables out, inspect and clean. Frayed, dirty, dry lubed cables can do this.
 

·
Premium Member
Joined
·
10,203 Posts
Welcome to the group.

The clutch adjustment is covered in the service manual (pm sent).

I've moved your post to the DOHC sedtion of the forum where you can find answers to many questions as well as some great light reading.

Got pictures?:p
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
I've tried and tried with the clutch and can't get the damn thing straight, the bike will jump forward when you kickstart it if it isn't in neutral.
 

·
Premium Member
Joined
·
2,838 Posts
Has the bike been sitting? The plates could be stuck and not a cable problem at all.
 
  • Like
Reactions: J-T

·
Registered
Joined
·
2,581 Posts
If the free play at the clutch lever is set, so you get full pressure on it most of the way to the grip, I'd also guess the plates are stuck. Very common on bikes that haven't been moved in a while.
 
1 - 7 of 7 Posts
Top