Honda Twins banner

1 - 4 of 4 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter · #1 ·
Wait do you guys think, I've been wanting to to pick up the Charlie's Place electronic ignition system for my 68 cl175. I already have a Ricks Motorsport regulator/rectifier for the bike (the electronic ignition requires this). I'm wondering if I'll be ok running the Ricks reg/rectifier with the Charlie's Place ignition system. I'd rather not have to spend another $125 on an already tight budget.
 

·
Premium Member
Joined
·
3,006 Posts
For what it's worth, I've been running a Charlies Place ignition on my CL175 for the last 18 months.

I'm using a regulator / rectifier as originally fitted to a '99 CB600 and a Motobatt AGM battery, works fine.
 

·
Registered
Joined
·
10 Posts
I just installed a Charlie's electronic ignition on the sl175 that I am working on...I have set the timing according to the directions that were available online but the bike is still backfiring and acting like the timing is off. It will also bog down while twisting the throttle...anyone have any suggestions?
 

·
Premium Member
Joined
·
3,006 Posts
Check that the advance and retard mechanism is free to move. When I installed my Charlies Place ignition I had similar symptoms, bike wouldn't pick up when throttle opened. It turned out that the rotor from the kit tightened down onto the advance mech, locking it in the start position. A thin shim under the rotor cured this.

The fault was with my bike, a previous owner had filed the end of the camshaft for some reason. Installed on another 175 engine without problems.
 
1 - 4 of 4 Posts
Top