Honda Twins banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hey everyone,

I recently drove down to Kansas City from Chicago for this 1969 Honda CB350 K1. It was a drive...but I really like the look of the tank. I had a CB125s, CB175, and a CB360T before. I've gotten some great information from the forum so far. Excited in becoming a new member. Great people here!

I recently took off the tank to clean it. I have rebuilt the carbs. The Keyster kits were the only ones I could find on ebay that had the same jets as mine. I did an oil change this weekend. I'm currently waiting for some fuel filters and also install a new YUASA battery. I plan on following the majority of what outobie's advice on this link: http://www.hondatwins.net/forums/49...uy-hope-doesn-t-discourage-you-looking-2.html

The PO said the electric start recently gave out and he did not know how to kick start it. When I got it I was able to get it started but I think it was running to rich. I smelled some fuel from the exhaust :eek:. Hopefully it was just that the PO tried to kick start to many times and nothing wrong with the top end. I also noticed the fuel bowl had not been adjusted properly to the carb specs. He also changed the spark plugs before I got it so I'm unable to tell how it was running before.
 

Attachments

·
Premium Member
Joined
·
1,928 Posts
Welcome to the forum. That is a very nice bike you picked up.

Ray
 

·
Registered
Joined
·
9,796 Posts
Welcome to the forum. You have a very nice looking bike there.
 

·
Premium Member
Joined
·
7,863 Posts
That looks very well preserved. great find!
 
1 - 7 of 7 Posts
Top