Honda Twins banner

1 - 4 of 4 Posts

·
Registered
Joined
·
203 Posts
Discussion Starter · #1 ·
I installed LED turn singals onto my 75 CB125. It has been converted from 6v to 12v. I also installed an LED signal relay.

Weird thing is that when I turn the left signals on, I get a little flashing on the right side. When I turn the right signals on, I don't get any flashing on the left. The bulb in the instrument panel works fine, but seems to be brighter when the right signals are on than the left ones.

I tried running the signals with instrument bulb removed - same result.

Any suggestions?
 

·
Premium Member
Joined
·
10,203 Posts
Clean and tighten the connections, especially the grounds.
 

·
Premium Member
Joined
·
3,006 Posts
You did the right thing in removing the repeater lamp bulb on the instrument panel, left in place it will allow current to pass to circuit on either side, due to the weird way Honda have wired it. Bulb is not grounded to frame ground, one wire from bulb goes to left circuit, other wire goes to right circuit. Take a look at the FSM circuit diagram.

Bulbs don't mind which way round that they are wired, LEDs do. For an LED setup, you either need a separate repeater lamp for right and left circuits, or you use a single lamp, LED or conventional, with two live feeds incorporating diodes, and a single ground feed.

And as JT says, check all your ground connections. Headlight ears in particular.
 

·
Registered
Joined
·
12 Posts
I bought an led lamp thinking that would fix it but it only blinks when the one blinker is on and not the other. I just disconnected it too. I was'nt going to rewire just for that snafu.
 
1 - 4 of 4 Posts
Top