Honda Twins banner

1 - 16 of 16 Posts

·
Registered
Joined
·
502 Posts
Discussion Starter #1
Not super exciting or crucial, I know, but I got a few of these yesterday and I put them in my gauge cluster this morning, and what a difference it makes brightness-wise! Now I can see the neutral light even if the sun shines directly on the gauge, which I couldn't before, and same thing if I forget to turn the blinkers off - can't miss it... 2 ambers, one green and one blue + 1 white. The blue in particular will transform the high beam light, it's a very pretty blue! :p

Bike is now 100% LED-powered.
 

·
Registered
Joined
·
502 Posts
Discussion Starter #4
:-D I was in a rush to get them in so I didn't get very good pictures, I think I should have made them darker to better see the difference, as it is it's not really striking, but it really is IRL...

Incandescents first (left bulb was blown out):
Gauges - Incandescent.jpg

LEDs (all on):
Gauges - LEDs.jpg
 

·
Registered
Joined
·
502 Posts
Discussion Starter #8
Nice!!! Do you have one or two bulbs per gauge? I thought mine was two but it turned out to be only one, so I guess I have a spare now... a dark light bulb would be kind of cool too... :-D
 

·
Registered
Joined
·
13,085 Posts
I have LEDs in the gauge illumination of my 450 and it is absolutely better... but I did use a standard bulb for the neutral light so it wouldn't be offensively bright at night (on the off chance I'm riding home from somewhere after dark with the 450, not generally happening)
 

·
Registered
Joined
·
502 Posts
Discussion Starter #11
Haven't tried it at night yet. Maybe I'll get a less bright bulb for the winter when it's dark when I leave for work :p
 

·
Registered
Joined
·
641 Posts
Has anybody tried the single leds ba9's they sell at SBL? I like the thought of only 0.4 to 0.7 watt usage they advertize.

Sent from my SM-N920R4 using Tapatalk
 

·
Premium Member
Joined
·
1,638 Posts
Sorry for the late response guys. I used 1 bulb per gauge (I think? I did this mod in like 2010...) and I used a white LED.
 

·
Premium Member
Joined
·
1,638 Posts
Did you use the same bulbs, man thats bright!

Sent from my SM-N920R4 using Tapatalk
Different bulbs. The ones that I used are so old, they don't show up on Google anymore. I think I got the link from DoTheTon.com back in the early 2010's...
 
  • Like
Reactions: chaindrivecharlie
1 - 16 of 16 Posts
Top