Honda Twins banner
1 - 9 of 9 Posts

·
Premium Member
Joined
·
3,047 Posts
Discussion Starter · #1 ·
I've got transparent fuel hoses on my CB175K4, and have noticed some fine sediment in the bottom loops of the hoses.

This coincides with my weak mixture / dirty main jets incident, so I'm thinking of fitting some inline filters. The fuel tap has a new OEM mesh filter in place, this seemed clean when I just checked it, fine sediment must be small enough to pass through it.

I flushed the tank out before refitting it, but I haven't derusted it, it didn't look too bad on inspection with a light through the filler cap.

Any issues with in line filters ?
 

·
Registered
Joined
·
342 Posts
I always use in-line fuel filters, cheap insurance. Others will disagree.
Your tank may not be as clean as you think. Rust has a way of getting around.
 

·
Premium Member
Joined
·
2,074 Posts
If they get a little clogged up, I suppose it could reduce your fuel flow a bit.
I have never had a need for them on my 350, but one of my ct70's had one on when I
bought it. I put a whole lot of miles on it over a few years and they never caused a problem.
 

·
Registered
Joined
·
539 Posts
Clean the tank. Best bet. Then you don't need 'em. One more place to leak. But, just my opinion.
 

·
Premium Member
Joined
·
3,047 Posts
Discussion Starter · #8 ·
Thanks for the reassurance folks.

I agree, cleaning the tank is the definitely the solution, and one that I will implement at some point. I've used the POR system successfully on another tank.

At the moment, this bike is a rolling rebuild, one that I want to get ready for the UK MOT test, and subsequent UK registration documentation. Once that is out of the way, the bike is going to be stripped and rebuilt properly, from the frame up. This is what I did with my CL, but that bike wasn't a runner like this one is.

Filters will be a short term solution, and I'm relieved to hear that there are no potential issues with doing this. Just that I had a vague recollection that I'd read that some folks had had problems.
 
1 - 9 of 9 Posts
Top