Honda Twins banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I was the surprise recipient of a 1971 CL175 K6 left to me by a cousin in his will. I have been reading this forum every day for the last couple weeks in an effort to learn about this bike and to resolve issues to see if I can get it to run. There are 13.7k miles on the odometer, which is about 750 miles more then when my cousin bought it 3 years ago. With that info I surmise it was running in the not so distant past. I have been making some progress - from immediately blowing a fuse when flipping the switch that either my cousin or the previous owner had installed under the seat, to now having a proper keyed ignition switch with all the electrical apparently working. The short was being caused by a black wire running to the right handlebar switches. The insulation had been rubbed bare where it exits the hole in the handlebar. I am de-rusting the tank and have thoroughly cleaned the carbs and hope to try starting it in the next few days. This forum has been truly invaluable so far and I have learned a ton. I am very appreciative of all who share their wisdom with complete strangers - THANKS!
 

·
Registered
Joined
·
13,085 Posts
Welcome - it's a fun place with some of the nicest people you'll find in a forum, so as you already know you'll enjoy it here. Plenty of knowledge here for the 175s and you're already ahead of the game simply by knowing it's a K6, Honda's way of denoting model differences over the years during the era where bikes were often held over and titles the following year when sold. someone will be along soon to offer a FSM (factory shop manual) if you don't already have one, and if not simply post in the appropriate area and you'll get one. Next assignment - post some pictures. We love them, and as we say around here... no pictures, didn't happen. :D
 
1 - 2 of 2 Posts
Top