Honda Twins banner

1 - 4 of 4 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
hey everyone have a honda cl450 and im thinking that my clutch is bad, i know that a few pieces of the fiber were missing on the friction plates, when i get the bike going it seems to blip a little bit at around 3000 rpms in 1st then 4000 in second and so on, im assuming its the clutch that needs to be replaced. right not im a little broke and dont have a lot of money at the moment, should i replace the few plates that had pieces missing from them or should replace all of the friction plates. also then should i replace the separating disks??? looking for a cheap but long lasting fix. please help. bike bandit gave a part number of 65446-001, and i found the friction plates in honda oem seals they were priced at around $50 shipped.

Thanks,
Brandon
 

·
Registered
Joined
·
134 Posts
if you replace one disc you should do all as a kit. the metal one depends on wear limits.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #3
ok so i got in the new friction plates and the bike is still slipping, i cannot start the bike at all, when i down shift into first i can push the bike and it will not move seems to be in gear. when you put it in neutral the bike will not start when the kick start is kicked, what do you guys think??? maybe the clutch springs are weak??? the cable is stretched too much??? any thing that you think of please let me know.

thanks,
Brandon
 

·
Registered
Joined
·
608 Posts
sounds like your clutch is adjusted to tight, (slips when trying to kick it over)
 

Attachments

1 - 4 of 4 Posts
Top