Honda Twins banner

1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I have a 1971 CL350 (I was told its a '71 but the build date is 7/70, I know most cars are built before their 'model year'). I had it registered as an antique while I was a student in VA, but now I'm registering it as a normal bike. My state inspection requires a chain guard which it didn't have. I ordered the one pictured below, it feels like it should be a simple install but I cant get it to line up with the clutch cover/mounting points. If I slide it inside of the clutch cover, it sits inside of the outer mount which doesn't work with the bolt configuration. If I have it lined up with the bolt, it sits on top of the clutch cover and doesn't line up with the rear mount. Should it go inside of the clutch cover? Any help would be appreciated, I attached pictures for reference.
Screen Shot 2019-06-10 at 11.33.02 PM.jpg
IMG_9884.jpg
IMG_3278.jpg
IMG_7380.jpg
 

·
Sensei
Joined
·
27,173 Posts
Take sprocket cover off....install guard.....put cover back......
Guard has three point mounting, and cover MAY be in the way of correct install...(Front inside edge of guard).....
 

·
Registered
Joined
·
3,136 Posts
Take sprocket cover off....install guard.....put cover back......
Guard has three point mounting, and cover MAY be in the way of correct install...(Front inside edge of guard).....
It is easier that way, but it should slide in there without taking that cover off. Massaging it a bit may be the answer instead of installing it in a bind.
 
1 - 5 of 5 Posts
Top