Honda Twins banner
1 - 12 of 12 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I’m trying to get my 1981 cm400a to start but I’ve realized there’s no spark and I’m assuming it’s coming from the cdi because there’s no power going to the coil and I was doing my research I see that it’s RARE to find one for a decent price and at that, new. I was wondering if anyone has came up with a new modern ignition/spark set up that cancels out the cdi box? If not what would be the cheapest route to get my cdi box fixed or replaced? Thanks In advance
 

·
Registered
Joined
·
1,745 Posts
Dumb question but did you test the stator. If the stator is good then its probably the CDI. They no longer produce a CDI for the A models. The CB,CM 400 and 450 A models all use the same stator and CDI. You will have to find a good used one. Worst case you can use the flywheel , stator ,and CDI from a T model but you will loose all safety features.

Bill H
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Dumb question but did you test the stator. If the stator is good then its probably the CDI. They no longer produce a CDI for the A models. The CB,CM 400 and 450 A models all use the same stator and CDI. You will have to find a good used one. Worst case you can use the flywheel , stator ,and CDI from a T model but you will loose all safety features.

Bill H
Yea I read up on a post on here about someone swapping over to the t model components but at that point I might as well just pick up a project t model and restart the build on that platform.. hopefully I could look around and find a used cm/cb 400 a cdi and hope it works when I plug it up lol. Thanks for the help Bill
 

·
Registered
Joined
·
1,745 Posts
The A models have second SCR gate that will increase the RPM s to compensate for the load from the torque converter. The also have a circuit to kill the motor if the bike is put in gear with the motor running and you lower the side stand switch. So no those CDI s wont work on the A models.

Bill H
 

·
Registered
Joined
·
1,745 Posts
Allen is right .As far as the non 400 A CDI I removed the CDI from a running 400 A and replaced it with a 400 t CDI . No spark from from the 400 T CDI . Put the 400 A CDI back on and it started right up. There are resistance differences between the stator on an A model and a T model so maybe the T model CDI wouldnt work with a A model stator.

Bill H
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #9 ·
Get a Factory Service Manual and go through the troubleshooting steps before spending another dime on parts you don't need.

There are resistance specs for stator, ignition pickup coil and a few other things that you will want to test.

Give this a good careful read: Ignition Diagnosis for CB/CM 400/450 and CB450SC manual...
Yes I have read this post over and over about 10 times already 😂 today is finally my day off so im going to break into the wiring and test out all the connections. Thanks for the help!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #10 ·
Allen is right .As far as the non 400 A CDI I removed the CDI from a running 400 A and replaced it with a 400 t CDI . No spark from from the 400 T CDI . Put the 400 A CDI back on and it started right up. There are resistance differences between the stator on an A model and a T model so maybe the T model CDI wouldnt work with a A model stator.

Bill H
Thanks for the input I appreciate your help with this! I tried to contact Rex but I’m out in California and I can’t give him a call so I emailed him and still waiting for a reply lol but thanks again hopefully he gives me a message
 

·
Registered
Joined
·
7 Posts
I had a no-spark issue with my 79 cm400a and the mechanic worked it down to being the CDI or the stator. I found an a-model CDI on fleabay and ordered it. Mechanic kidnapped a stator from a spare motor and that ended up being the issue. I kept the extra CDI because I heard the CDIs for these are worth their weight in gold. I have heard that there is a company overseas some where that makes a programmable CDI replacement option but when I looked it up last year it was super expensive… and the slow-boats aren’t allowed to dock these days so I’m assuming it would be even more expensive.
 

·
Registered
Joined
·
24 Posts
All of the above + an upvote for blaming the stator. Those early 400s had problems there, way more than the CDI box.
A mile from my house in Colorado is this place, and I have seen one if not two 400A bikes on his lot. He might well have CDI and/or ignition stators.
Call him at 303-678-5683 (number from the photo) ONLY on Sunday between 12 noon and 3 pm Colorado time. Those are his hours and you'll get nowhere any other time.
Good luck !
 
1 - 12 of 12 Posts
Top