Honda Twins banner
1 - 2 of 2 Posts

·
Registered
Joined
·
489 Posts
Discussion Starter · #1 ·
I finally passed my CD175 to the inspection and now it is legal for street riding. But I have a small problem. The gas cap vent doesn't work properly. I ride for a while and the engine stop. I found that the gas doesn't run to the carburetor. So I opened the gas cap and the gas flowed again. I tried to clean it, passed high pressure air on each side and the middle hole. Some garbages went out. But it still blocked. I can ride for longer time but sometime the engine stop and I have to open the gas cap. It anyoing


I looked at the cap and it seem to be assembled by pression. I do not see how to disassemble it. Is there any trick? I had it chromed and I don't want to damaged it trying to dissasemble it.

IMG_0699.JPG

IMG_0701.JPG

IMG_0700.JPG
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #2 · (Edited)
I found the problem. The hole on the bottom and the two on the side are in the gas tank and sealed with the gasket when the cap is on the tank. So it need to have a place somewhere to take air. On off road bike, we usualy have a tube in the middle of the cap. On this one I didn't found any place where it can take some air. So I decide to do 4 small holes around the inside of the inner part of the cap (first picture).

Not long after that I looked for some pictures on the net and found this is exactly what it needed. On that one, there's only 1 hole (second picture).

The hole was probably blocked when they did the chrome.

I didn't had a chance to do a test ride and there's rain comming here for the weekend but I'm 100% sure about that modification.
 

Attachments

1 - 2 of 2 Posts
Top