Honda Twins banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
CB500T - Upon full throttle at speed just drops out completely bogs down like its out of gas or something but its getting fuel, checked plugs, carbs, jets, fuel , floats, asked all around and most seem to lean towards the mechanical advance. So I took a look, springs seem fine but i have no real way of knowing - suggestions please?
i was looking to replace the system with an electronic ignition but all those available now do not delete the mechanical advance so im leary to lay out the cash for a system that may end up not even solving the issue. I have seen NOS advancers available but once again is there a way to test the action of these units more reliably before shelling out for the NOS unit? All help greatly appreciated. Beautiful weather has arrived and i can't get back on the road reliably.
 

·
Registered
Joined
·
4,458 Posts
Get a timing light and check your ignition timing, especially on full advance (3000-4000 rpm)
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Does anyone know another model that the mechanical advance will match up with? Finding a replacement is proving difficult. Hoping someone knows of another model that might fit and provide a close enough advance to the CB500T original to get me back on the road - Thanks
 

·
Registered
Joined
·
48 Posts
Don't know of one but like the previous post if you have a timing light throttle up to 4,000 or so you can see if it advances correctly. eBay does have a used one right now for 19.00 I just saw - not sure how good it is but looks ok after you clean up and lube etc. Just got 350 miles on my 75 cb500t after back on the road from a shed find. It was running rich and could not get it leaned enough but switching to a hotter nkg 7 instead of the 8 changed everything for me - now runs great. Don't forget the carb adjustment- that would not allow it to throttle up - just slightly one turn out on my gas/air.
 

·
Sensei
Joined
·
27,164 Posts
CMSNL has one (and only one) for about $75 US......

Did yours vanish or is it actually bad?.... Have you checked with a strobe?
 

·
Registered
Joined
·
3,042 Posts
Before you start throwing parts at it, get a timing light to see if that is actually the problem. Your gonna need one anyway to properly set the timing.
 

·
Premium Member
Joined
·
2,838 Posts
Run it until it bogs down then pop gas cap and see if it picks back up, if so vent is clogged.

Doesn't sound like an advancer to me, the one time I had a bad advancer it would act like a governor, power to a point and then would hang there, no bogging, no missing.
 
1 - 8 of 8 Posts
Top