Honda Twins banner

1 - 3 of 3 Posts

·
Registered
Joined
·
255 Posts
Discussion Starter #1
1) I am noticing that my clear plastic fuel filter looks like it is empty when I am driving. Is my petcock clogged or is this normal?

2) My reserve does not work. Are the gaskets available if I take it apart? What is the likely cause of the reserve not working?


Thanks,
Larry
 

·
Registered
Joined
·
234 Posts
When I took my petcock apart, the reserve filter was shot - you should have a long tube sticking up from the petcock when you remove it (main fuel) and another part sticking up that on my 350 was a filter (reserve). The rust/sediment from the bottom of the tank had wrecked it so it would not have worked on my bike either. The other thing to check is the valve - if it sits dry for a while (or if its just plain old) the rubber piece that keeps everything sealed may have broken down and clogged. On the 350 you just take the two screws off the little bracket in front and the switch will come out, and behind this is where the rubber part should be. I'd order a new one anyway. check bikebandit.com, they have a good selection of OEM parts, and you can find the schematic of every part on your ride.
 

·
Registered
Joined
·
140 Posts
It's fine for them not to be full of fuel as long as there's enough fuel in the tank. As fuel gets removed from the float bowl, more fule will be allowed to flow through the fuel lines / filters. It's a gravity feed system. Try shutting off the petcock, removing a float bowl, dumping out the fuel from the bowl, reinstall the bowl, turn the petcock back on and watch the fuel flow through it.
 
1 - 3 of 3 Posts
Top