Honda Twins banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey guys, new to riding in general. Made a probably bad decision and bought an 82 cm450a for cheap and it needs some work. I've finally got it running pretty good and it's idling fine but if I give it too much throttle it doesn't respond too well but this only happens when it's in gear. In neutral it responds just fine. If I work a bit slower it runs just fine and gets as fast as I need it. Just curious if you guys had any pointers on what I can do to improve the throttle response.
 

·
Registered
Joined
·
555 Posts
When you say it doesn’t respond well...does it stumble? Slow to come back to idle? More detail will help us help you :)
 

·
Premium Member
Joined
·
24,208 Posts
Is the air box and those boots in place? If not then that's likely the problem.
Does the accelerator pump work? You should see a squirt at the nozzle next to the choke plate when twisting the throttle fast.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
My bad. It's just slow to speed up if I give it too much. Rpms will stay the same or even drop a little bit for like 2 seconds then it will pick up and get to speed just fine. It will come back down to idle just fine. No problems with going fast or staying at a constant speed.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
Cables snap back just fine. Also, update. I ran it for a bit today and the issue went away after it heated up. Had to adjust my idle screw mid way through riding though. Spark plugs maybe? Love this thing but it's a real pos sometimes
 

·
Premium Member
Joined
·
24,208 Posts
OK, now that she's rideable add some Sea Foam or Berryman's B12 to the tank for 2-3 tanks of fuel. This helps clean jets and passages that may be slightly dirty. Follow the directions on the can exactly.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
Sea foam done. Basically runs the same but smoother now. I have to tweek the idle screw after it's hot but, it's running like a champ. Checked my plugs and they look old so I ordered some new ones. Thanks for the help guys. ?
 
1 - 10 of 10 Posts
Top