Honda Twins banner

1 - 13 of 13 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Hi.
I put new floats and needles in and now it won't hardly rev .
I completely stripped and rebuilt the carbs . It was revving out fine before but leaked fuel. It's now not leaking and fuel is staying where it should. Took carb to local shop and he checked it and float heights are good. At a bit of a loss tbh as I do not want to throw anymore cash at it until it's starting and running as it was. I know everything is pointing at the needles . Running ram air filter pods so not original.
 

·
Registered
Joined
·
4,458 Posts
Need more info before people can help you.
What bike?
Why did you replace the floats and needles? What was wrong with the original ones?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
Need more info before people can help you.
What bike?
Why did you replace the floats and needles? What was wrong with the original ones?
81 400 SD . With a 450 motor out of a nighthawk.
Original floats and needles caused the fuel to pour out of the carb. That problem is now fixed but it won't rev, it's like a massive flat spot off of tick over.
This was revving great before the change.
 

·
Registered
Joined
·
4,458 Posts
Have you tried it without the pods?
Did you check to make sure you're getting good spark out of both plugs?
Check your ignition timing? Is it advancing properly?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #5 ·
Have you tried it without the pods?
Did you check to make sure you're getting good spark out of both plugs?
Check your ignition timing? Is it advancing properly?
Yes with and without filters
Good spark off plugs
I haven't touched the timing. Very few electrics on it to be fair.
Battery>starter solenoid >regulator.

Maybe I need to check the valves. Maybe they're gummed up . When it did start it stunk so maybe that's something to do with it.
 

·
Premium Member
Joined
·
10,203 Posts
Just to clarify, was it running good with the pod filters before you changed the float needles or did you change to the pods at the same time?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #8 ·
Just to clarify, was it running good with the pod filters before you changed the float needles or did you change to the pods at the same time?
All running with pods before I changed needles and floats.
 

·
Registered
Joined
·
500 Posts
What about going back to the original floats and needles? You can just clean them.Did you get OEM replacements? Some after market needles are too long. Did you read the Rebuilding VB Carbs tread, might give you a clue?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #10 ·
What about going back to the original floats and needles? You can just clean them.Did you get OEM replacements? Some after market needles are too long. Did you read the Rebuilding VB Carbs tread, might give you a clue?
All the old bits where shot. Float needles where badly worn, hence petrol pouring out of the overflow, this is now fixed and the float bowls fill up fine. So this says to me that the needles are the correct length, I think I even measured them and they where the same. I will double check them tomorrow if I can find the old ones.
 

·
Premium Member
Joined
·
24,208 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #12 ·
Thanks . Read that last night and ordering some 54mm silicone tube. Jetting will be trial and error as it's a 450.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #13 ·
Well. Drilled the jets out and now runs much better, even with the ram air pods. So its getting there. May even get this winter project done after 3 years or so.
 
1 - 13 of 13 Posts
Top