Honda Twins banner

1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Good evening,
I have been poking around the forum but I can't quite find the answers.
My neutral light is on for both 1st and Neutral. How can that be adjusted?

The new flasher that the PO installed has two terminals but there are three wires to be hooked to it. I guess I need a three terminal 6V flasher to get the light by the speedo to work?

Thank you all over again,
Justin
 

·
Registered
Joined
·
1,364 Posts
Year, make, model ... this will expidite a response...
 

·
Premium Member
Joined
·
24,208 Posts
Moved to SOHC Electrical section,
The neutral light is controlled by the switch in the case, that's the ground. I'd disconnect that first and see if the light stays on, if so then there's a pinched wire creating a ground. If not then the switch is probably sticking internally, remove it and clean the plunger with carb cleaner or electrical spray.
The 3rd wire for the flasher is a ground wire that only some flashers need. It's a solid Green wire. If the light in the cluster is the only thing not working then it's probably the bulb burnt out or bad contacts
Helps to post year and model of the problem bike for future questions
 

·
Premium Member
Joined
·
24,208 Posts
.... or I could be wrong...:)
I cheat and look at previous forum posts to see if I can identify the bike in question for those posts. The cheat is to click the members name and a window pops up "View Forum Posts", click that and scroll thru
 

·
Registered
Joined
·
87 Posts
Seems like your neutral switch is sticking. Common on the Twinstars. No, there is no adjustment for this switch. You can clean or replace the switch. You have to take the stator cover off to get to it. It's held into the case by a bolt. (8mm ?) A lot of work/time just to change the switch.
Please do not try to clean this switch while it is still in the case! Any type of cleaner will seep into the case, contaminating the oil and possibly ruining the clutch.
Don't worry about the "third" wire for the flasher, it's not needed. Connecting it will not solve your problem.
 
1 - 7 of 7 Posts
Top