Honda Twins banner

1 - 3 of 3 Posts

·
Premium Member
Joined
·
201 Posts
Discussion Starter #1
Hi all, I recently put my bike back together and when I fired her up once she wouldn't shut off after turning the ignition key to off.

It did this only once after like a dozen starts. Basically I kick started the bike and put her in first, riding it a few feet then I put her in neutral and turned the ignition key to off, but the bike stayed on.

It only happened once even though I tried to get it to happen again. I am thinking it's an electrical issue probably in my headlight?

Any thoughts?
 

·
Premium Member
Joined
·
1,003 Posts
bk69cb350 said:
Hi all, I recently put my bike back together and when I fired her up once she wouldn't shut off after turning the ignition key to off.

It did this only once after like a dozen starts. Basically I kick started the bike and put her in first, riding it a few feet then I put her in neutral and turned the ignition key to off, but the bike stayed on.

It only happened once even though I tried to get it to happen again. I am thinking it's an electrical issue probably in my headlight?

Any thoughts?
Crap in the ignition switch from sitting to long. You can disassemble them and clean them, a little bit of a fiddle but when done whith a nice cup of coffee a good experience :lol:

EDIT: Use only dielectric grease when reassembling ;)
 

·
Premium Member
Joined
·
201 Posts
Discussion Starter #3
Ok thx, I will give the ignition a look if nothing in the headlight seems out of place.

Thx.
 
1 - 3 of 3 Posts
Top