Honda Twins banner
1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi All- SO my Speedo wont shut up! ( The standard whiney squeel )

After reading and watching videos, seems like everyone lubes up the cable, except one video I saw a guy working on the back of the speedo cable input.

I cant tell where the whine is really coming from - but I think its the speedo itself. I rode the bike with speedo un-attached and there was no noise.

A few weeks ago I lubed up the inside of the back of speedometer input and the noise went away, but came back fairly quickly within a few days.

The needle also bounces like crazy- So I was thinking I could disassemble the whole unit and see whats up. Removing the 2 screws on the back of the speedo just loosens the internal assembly, so I assume it must be removed from the front ( but didn't want to attempt any further and break the plastic or face glass??

Any thoughts on next steps?

Thanks!
 

·
Registered
Joined
·
4,402 Posts
I have removed/cut the upper face/plastic window on one of those plastic speedos, removed the mechanism inside then glued the face/window part back on after I was finished(it will look like it's been glued back on though..) using strong plastic glue for ABS called "Plastic Surgery" and the mechanism is good now.The other option would be to find a good used speedo on Ebay,etc.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Fixed it.

I removed the unit and inserted the correct sized square bit attached to a drill. Its for sure the internals of the unit itself making the squeal. A few drops of bike chain oil dropped in and its back to quiet as can be. 100 miles later its still quiet.

I think having the speedo removed and upside down for the lube to really penetrate the internals was key. Just not too much or risk getting it in the inside of the gauge face!!! ( i didnt.. just saying)
 
1 - 3 of 3 Posts
Top