Honda Twins banner

electric

  1. Electrical Discussion
    Hi, I just picked up a non-running CL175K6, got it running but now I'm looking into some electrical issue. In the second key position the tail light will come on like it's supposed to, but when running normally none of the lights work at all. My first thought is the old rectifier needs to be...
  2. Electrical Discussion
    Hello All, I don't know what to do. I bought a 1978 Twinstar at the end of summer here and when I bought it I knew that the signals didn't work. I was dumb, and didn't check the brake light, which also didn't work. So after some time spent on the bike here's where I'm at with it: - Turn...
  3. Vendor Links
    The stator on my cm400a went out almost two years ago it took me 2 weeks and dozens of phone calls to find a salvage yard in the United States to that had another one. Flash forward to now-this "new to me" stator has gone out. Knowing how hard it would be to find yet another one I looked for a...
  4. Electrical Discussion
    Hey guys, I've hit a bit of a wall and need some help/advice. I was out riding my 1971 CB350 last week and all was completely normal. 15 minute ride to a store, then I made a 10 minute stop and headed to another destination to make a second stop which lasted 5 minutes. The bike gave no...
  5. Electrical Discussion
    Hey everyone, I'm a new member here around the forums and not the most mechanically inclined, so please try to bear with me! I really do appreciate any help that you can offer. So, a couple days ago I purchased a 1980 CM200 Twinstar as a starter bike to use around town and for my short commute...
  6. Electrical Discussion
    Hi, I just bought a 1969 CB350, and the PO said it was a 6V system. I'm not convinced that it is a 6V system, but I wanted to ask someone, and I knew the folks on here would know. Anybody?
Top