New Member in Southern California - Page 2
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
Like Tree2Likes

Thread: New Member in Southern California

  1. #11
    Senior Member Rothafella's Avatar
    Join Date
    May 2015
    Location
    Motown, WV
    Posts
    426
    Ha! Just saw your question posted the forum, so I am sorry for missing that here. Hopefully someone more familiar with Rick's will be able to help!
    1973 CL350 "Claudia"

  2. #12
    Junior Member even_keel's Avatar
    Join Date
    Jan 2017
    Location
    CA
    Posts
    20
    Quote Originally Posted by Rothafella View Post
    I think most of us have been there! I went the Sparkmoto route but I have heard good things about Rick's units. Made a huge improvement in how the bike ran, even with the battery always being tended. Hopefully you will be able to get that sorted out and get her running awesome again. Feel free to ask questions if you encounter issues..
    Thanks, I really appreciate it. I have a thread up in the 350 electrical section trying to figure out what to do with all of the leftover/non-essential wiring the Rick's unit will be replacing. I came from the air cooled VW world so I've seen my fair share of bastardized wiring.
    Rothafella likes this.

  3. #13
    Junior Member even_keel's Avatar
    Join Date
    Jan 2017
    Location
    CA
    Posts
    20
    Quote Originally Posted by Rothafella View Post
    Ha! Just saw your question posted the forum, so I am sorry for missing that here. Hopefully someone more familiar with Rick's will be able to help!
    No worries at all. Just trying to un-cluster some of this crazy wiring!

Page 2 of 2 FirstFirst 1 2

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •